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Welcome to Teleprompter!
Congratulations on your purchase of Teleprompter! This user guide hopes to answer 
any common questions you have regarding Teleprompter, as well as educate your 
usage of the software so you may take full advantage of its capabilities.

If at any time you need help with Teleprompter, visit pavonine.co/teleprompter/support 
for additional support.

Using this Manual
This manual often uses formatting to denote what phrases refer to.

For example,
Italicized phrases refer to elements of the user interface or key phrases.
Underlined phrases refer to other sections of the manual or user interface.

Common Phrases
Throughout this documentation, certain phrases will used repeatedly. It’s important to 
understand what they mean so you may fully understand the documentation.

Script, Document
The script or document represents one Teleprompter file, consisting of a text, speed, 
timing information, and overlay settings. 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Interface Overview
When you open up a new Teleprompter document, you’re greeted with the following 
interface:

1. Opens the overview side pane. For more on the overview pane, see Overview.

2. Displays the current time of the script. Click here and enter a time index to scroll to 
that time.

3. Toggles the controls HUD (Heads Up Display). With the controls HUD toggled on, 
you cannot edit the script’s text. However, prompting controls are displayed, and you 
may use the space bar and other keys to control prompting. The Opacity slider 
controls the opacity of onscreen controls. For more on the Controls HUD mode 
interface, see Controls HUD.

4. Stops movement of the script and moves to its beginning. You must unlock this 
control before using it by clicking the lock to its left. The purpose of the lock is to 
prevent unwanted clicks during presentation.

5. The Reverse control starts the script moving backwards, while the Play control starts 
moving the script forward. When the script is either playing or reversing, the 
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respective control changes to a Pause control. Click the pause control to stop script 
movement, or the other control to switch direction.

6. Controls the speed of the script. The grey AUTO indicator indicates the automatic 
timing speed, when the speed mode is in auto.

7. Choose between either AUTO or Manual speed modes. In Manual mode, the speed 
is controlled manually via the Speed slider, via remote control, or via the Prompt 
interface. In AUTO mode, Teleprompter controls the speed of the script 
automatically based on timing settings in the Overview or Script Panes. In AUTO 
mode, manual interaction with the Speed slider is disabled. For more about 
automatic timing, see Automatic Prompting.

8. The Script, Overlay, and Screens buttons open their respective side panels. For 
more information, see Right Side Panels.

9. The text entry area. Start typing here to enter the text of your script. For more 
information, see Text Entry. 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Text Entry
Teleprompter includes a full rich text editor, just like TextEdit.

To begin editing text, make sure the HUD (Heads Up Display) Controls are disabled.

PICTURED: CONTROLS ARE DISABLED

Now, you can begin typing text into the prompting area.

Teleprompter supports many text formatting features. Access them through the Fonts 
and Colors buttons in the script sidebar, or under the system-standard Format menu.
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Change the background color of the script by clicking the colored square in the 
Background Color section of the Script sidebar. Then select a color in the menu that 
appears.

Copy & Paste
You may also paste text into the teleprompter using Edit > Paste and Match Style or 
⌘V. The text will automatically change to the formatting of the text in the script. (You 
can change this in Preferences.) Remember that black text against a black background 
will not show up. To paste with the text’s original formatting, use Edit > Paste or 
Command+Option+Shift+V. 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Automatic Prompting
Teleprompter has comprehensive automatic prompting features that allow you to 
precisely time the prompting of your script. First, let’s go over some automatic prompting 
terms:

Terms
Marker
A marker connects some point in the text to some point in time. By calculating the 
distance between makers, Teleprompter can figure out at which speed to prompt the 
script.

Segment
A segment is the space between two markers. It has two endpoints both on the script 
and in time.

Using Automatic Prompting
To configure markers, use the overview, described in the next section.

Once you’re ready to use automatic prompting, set the Speed Mode 
control to Auto. To resume manual prompting, change the Speed Mode 
selector back to Manual. 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Overview
Click the Overview button on the far left left side of the toolbar to open the overview 
panel.

Overview Elements
On the left side of the overview pane, your script is shown in a zoomed out form. On the 
right side, a time ruler from your script’s start time to your script’s end time is shown. 
While the time ruler doesn’t directly correlate to the script, it allows you to see the 
relationship between the segments. The overview interface works much like a video 
editor.

When you move the pointer over the 
overview display, the Time display change to 
the red Overview Time display. This tells you 
the time in the script that your cursor is over.

This indicator shows at which position the 
script is currently at.

This is a timeline marker. It shows a 
connection between a place in the script and 
a time index.

Selected timeline makers are green. Press 
delete to delete selected timeline markers. To 
select timeline markers, hold down shift or 
command while selecting to select multiple 
markers.

As you skim your pointer over the overview, it 
is followed by a red line. This line shows the 
corresponding positions in both the script and 
time.

Right click anywhere in the overview to bring 
up a contextual menu. From there, you can 
insert a new marker, or jump the script to that 
point. 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Using the Overview
Insert overview markers by right clicking in the overview and selecting Insert Marker or 
by pressing Command + Shift + B with your mouse hovering over the overview.

Tips and Tricks

• If using a trackpad, pinch to zoom the overview in and out.
• Double click in the overview to jump the script.

Moving Markers

To move a marker’s position in the script, drag the side of the line in the script.
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Drag to move. This red mark shows the marker’s position.
This button controls whether 
the script previews where 
the marker is.



Mouse down over the marker’s text position to get a preview of where it is.

Drag the marker line on the time side to adjust the marker’s time. Depending on where 
on the line you drag, the effects of your drag are different.

Drag here to adjust the length of the 
segment before the marker.

Drag here to adjust the position of the 
marker, thereby adjusting the length of 
the segments both before and after it.

Drag here to adjust the length of the 
segment after the marker. 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Right Side Panels

There are three settings menus on the right side of the Teleprompter window. Click a 
button to open the respective panel. Click the button again to close it.

Script
The script panel has settings pertaining to the 
script in general.

Text

The Fonts and Colors buttons are shortcuts to 
the system-standard settings menus.

Click the color box next to Background Color 
to change the background color of the script.

Flip

Choose to flip the script in the main window 
vertically, horizontally, or both.

Timeline

The timeline controls control the automatic 
timing of the script. Choose whether to use 
automatic timing, and choose a start and end 
time. These settings correspond to those in 
the overview. 

�12



Overlay
The overlay panel contains settings relevant to showing an image overlay over the 
script.

Firstly, check the box if you would like the 
overlay to be shown in the main window.

Overlay Image

Choose an overlay image by dragging or 
pasting one into the image box. Or, open it 
using the Open… button. Click Reset to 
Default to reset the image to the one 
defined in Preferences

Colorization

Check Colorize and choose a color in the 
right-hand color square to tint the image to 
the color of your choosing.

Opacity

Change the opacity of the overlay. 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Screens
The Screen Resolution table lists 
available screen resolutions. The 
script will lock to the selected size. 
Click Changes With Window if you 
want the script to change with the 
window size.

To add a new resolution, enter the 
width and height in their respective 
boxes, then click the + button.

Connected displays show up in 
the Show Script on Screens: 
section. Check the box next to a 
display’s name to show the 
script on that display. Click the 
gear button to open 
configuration options for a 
display. Click the arrow pairs to 
change the flip of the display.

To create a clone of the script, 
click New Clone Window. A new 

window will open that contains a copy of the prompting script. We will explore 
clone windows in the next section. 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Clone Windows
When you click New Clone Window in the Screens panel or select File > New Clone 
Window from the menu, Teleprompter creates a new clone of the script.

Use the clone window as you would any other window. You may create as many clone 
windows as your computer can run. Read more about the prompting HUD in the next 
section. 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Flip Arrows. Click to 
flip the clone only.

Toggle the overlay in 
the clone.

Toggle the prompting 
HUD (Heads Up 
Display) in the clone. 
Use the slider to the 
right to adjust its 
opacity.

Lock the clone to the 
current display.



Controls HUD (Heads Up Display)
When the Controls HUD is toggled on in the main window or in a clone window, the 
prompting HUD is shown over the script. When the controls are shown, Teleprompter’s 
performance improves as it does not have to support text editing.
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Speed Mode Selector: Choose MANUAL 
for manual prompting, choose AUTO for 
automatic prompting. The speed slider 
will be disabled in AUTO mode.

Speed Slider: In MANUAL mode, click and 
drag or use the + and - keys to change the 
script’s speed. When the script is playing, 
you may also scroll to change the speed. 
Speeds are measured in pixels per second.

Play: Click or press the spacebar to play the 
script. Click or spacebar again to pause.

Reverse: Click or press the 
spacebar to reverse the 
script. Click or spacebar 
again to pause.

Reset: Click the lock to unlock 
the reset button. Click the 
reset button to stop the script 
and move it to the beginning.



Preferences
To adjust Teleprompter’s preferences, select Teleprompter > Preferences from the menu 
bar.

The preferences menu is broken up into three categories.

General

Use Command+V for “Paste and Match Style”

When this box is checked, pressing Command + V when entering text pastes the text 
with the same formatting as the rest of the text. This is intended to prevent you from 
pasting black text on a black background.
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Maximum Speed

Set the manual prompting’s maximum speed, in pixels per second.

Hotkey Speed Increment

Set how much the speed changes when you hit the + or - keys.

Drag Time Interval

Set the snapping time interval of markers in the Overview.

Reset Preferences

Reset all Teleprompter preferences. This cannot be undone.

Overlay
The overlay preference pane provides a set of default overlay values to be used in new 
Teleprompter documents. This pane works very much like the Overlay section of the 
Right Sidebar.
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Remote
The remote pane controls preferences relating to Teleprompter’s remote control 
capabilities.

Un-check Allow Remote Control to completely disable Teleprompter’s networking 
capabilities.

Check Require Password and enter a password in the box to the right to enable 
password based authentication. Any devices wanting to control Teleprompter must 
authenticate using the given password.

For more on remote controlling Teleprompter from another Mac or iOS device, see the 
next section. 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Security Notes:
• The password is never sent over the network in plain-text, and is stored on each 

device in its respective keychain.
• While password protection will prevent unauthorized clients from connecting to 

Teleprompter, it will not protect against denial-of-service (DOS) attacks. For 
optimal security, use Teleprompter only on a closed, secured network.



Remote Control
Before using the remote control feature of Teleprompter, some conditions need to be 
met.

• Teleprompter must be running on the Mac you wish to control. Allow Remote Control 
must be checked in preferences.

• The Teleprompter Controller app, available on the App Store, must be running on 
the controlling iPhone.

• Both the Mac and the iPhone must be connected to the same supported WiFi 
network. Teleprompter remote control may not work on some networks. If you are on 
an unsupported network, or no WiFi network is available, Teleprompter supports 
Bluetooth remote control. See Using Remote Control via Bluetooth.

Using Remote Control on an iOS Device
After verifying that the above conditions are met, launch the Teleprompter Controller 
app on your iPhone (or iPad).

When you launch Teleprompter 
Controller, you are presented with a 
list of available scripts found on the 
network, under a heading of which 
Mac they are on.

Secured Macs requiring a password  
are denoted by a “🔒 ” symbol. If 
you haven’t already entered the 
password for this Mac, or the 
password has change, you will be 
prompted for a password when 
selecting one of its scripts.

Select which scripts you wish to 
control. A blue check mark will 
appear indicating which scripts you 
are controlling.

Flip the Dark Mode switch to 
change Teleprompter Controller’s 
interface to make it more friendly for 
dark rooms.
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 SELECT THE SCRIPTS YOU WANT TO 
CONTROL. SELECTED SCRIPTS ARE 
MARKED WITH A BLUE CHECK. TAP DONE 
WHEN YOU ARE DONE.

 PASSWORD-PROTECTED SERVERS 
REQUIRE YOU ENTER A PASSWORD.



Once you’ve selected scripts you wish to control, tap Done to bring up the controls. This 
interface uses concepts similar to those found elsewhere in Teleprompter. Below is an 
overview:
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Speed Slider: Drag to 
adjust the speed of 
prompting. Disabled in 
Automatic speed mode.

Play and Reverse 
Buttons: Tap to play or 
reverse. Tap again to 
stop.

Reset Button: Tap to 
stop prompting and 
return the script to its 
beginning. A 
confirmation dialog 
makes sure you want to 
reset.

Speed Mode: Tells the 
script to use either 
automatic or manual 
prompting mode.

Indicates how many, if 
any, scripts you are 
controlling.

Go back to script 
selection.



Using Remote Control on Another Mac
You may also control Teleprompter from another mac running Teleprompter. The same 
conditions must be met as for an iOS device.

First, click File > New Remote Controller in the menu bar to open a new Remote 
Controller.

The interface of the Remote Controller is almost exactly the same as the iPhone 
controller. A list of scripts is on the left, and controls are on the right. You must unlock 
the Stop button.

Using Remote Control with Bluetooth
While Teleprompter and Teleprompter Controller are capable of communicating with 
Bluetooth, there are some special considerations to keep in mind.

Requirements for using Bluetooth:

• Both devices must have Bluetooth activated.

Notes about using Bluetooth with Teleprompter:

• Remote control over Bluetooth has noticeably more latency than using WiFi. Control 
inputs will take longer to register remotely, and there may be a delay in finding 
available scripts on the network.
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• Bluetooth devices may sometimes not see each other. If this occurs, go the Bluetooth 
menus on each device and pair them to each other.
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Contact Information
If you require more assistance than this manual can provide, or if you have comments 
or questions regarding Teleprompter, visit pavonine.co/teleprompter/support to contact 
Teleprompter support.

Thanks for using Teleprompter!
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